FANDOM


I found a Clockwork Donor at ( -1153, 94, 1030 ) /waypoint -1153, 94, 1030. I double-clicked to collect it and I "find a salvageable encephalocortex." I received the encephalocortex in my inventory, turned it in with no problem and am now proceeding to the next part. Meggaplex 06:51, 24 March 2008 (UTC)

wait a few secs before using the remote Edit

I had to wait 10 secs between casting the Chirurgeon and using the remote. If you use the remote too quickly, then it fails to possess the Chirurgeon. 80.47.216.92 13:18, May 28, 2010 (UTC)

Quest changed. Level dependent and auto update Edit

I tried to do this quest at level 39 or 40 and was unable to use the device. I had dismissed my mercenary and pet. Somewhere I read it was level dependent and decided to try again another time.

Leveled up to 41 or 42, and was out harvesting clockworks for a different quest, when one that I targeted I was unable to attack. I tried double clicking and harvested the Encephalacortex. I had both the kit and remote control in my inventory. Of note, both my warder and my mercenary were up when this happened.

It appears this quest has changed. I am not sure if the part I tried before my level increased set the update that I got later, or if the whole thing updated after I leveled.

Penstar (talk) 11:40, June 27, 2016 (UTC) Bluedragyn - Maj'Dul

Community content is available under CC-BY-SA unless otherwise noted.