01/13/2013 I tried the last two methods, niether worked however when I tried the method of first planting the one at Sinephobis feet, than taking cloud to Gazer Island, log to char. select, than loging back on. I was able to plant it right on the pad. I than too cloud to Bixie, than logged to char. select. Logged back on than planted the rod right on the pad. and was completed in under 3 Min. no other way worked it would not let me plant the rods anywhere they would not light up for me, however when i logged to char. select and came back they lit up and planted just fine. Tullipana

Placing the rods - The pre-last step seems buggy at the moment. But i found out how get this to work. Start with placing on bixie island directly near the cloud station, than placing on gaza island, also directly near the cloud station. Finally placing the last rod in front of the NSC there you started - with a carpet or something like that the time is enough to do it. All other ways not worked for me.

If you want to include this information: I harvested two pieces for this quest in The Loping Plains.

You can also spawn Do'Ellin the Young with the character working on the quest, log to your level 80 main, beat it down to 10% and then relog again. The drake stays about 1 minute in the subdued form. This way you can do the quest solo till the last step.--Alinor 07:25, 19 March 2008 (UTC)

Placing the Rods Edit


  • This all seems to have been fixed? I had no problem clouding between the isles and placing each rod.

Saw-lau (talk) 23:38, September 23, 2019 (UTC)


  • flying mount appears to alleviate all issues. if you don't use the ports, the rods work exactly as advertised..they grey out when you get close, highlight when you're far enough away, no matter where you are on any of the islands.


  • November, 2011. Verified that the best way is that you should use the /camp to yourself because of the bug. Luckily, there's plenty of time. The only pita is having to regroup and rebuff.
   - Confirmed 9/15/2012
  • This needs confirmation but worked for both me and my wife, simply use the cloud to go to Tenebrous Landing between each island. Doing this allowed us to place the rods before we even got off the station only ended up taking us a min or so. To clarify, place on Isle of Fear, cloud to Tenebrous Landing, cloud to Gazer Isle and place rod, cloud to Tenebrous Landing, cloud to Bixie Isle and place... done!
    • I can confirm that the above mentioned method does indeed work without any issue whatsoever. --Arcturys August 5, 2011
    • I can also confirm that this method work for me the first time I tried it. Sakshale (talk) 06:19, November 30, 2012 (UTC)
  • Instead of looking at the discussions, let me spell out what worked flawlessly on 06.02.11. Immediately after getting the rods, place one at Sinephobis. It takes a bit to cast, but don't worry. Afterwards, add the rods in your inventory to your hotbar. Once done, teleport to Bixie Isle. Use the camp command (/camp) and log out. Once logged out, log back in and immediately click the hotbar icon for the rods. You should still be at the cloud wisp thing. Once done, use the wisp thing to teleport to Gazer Isle. Use the camp command again. Once logged out, log back in and immediately place the rod. This should have you finished with over 3 minutes to spare. Gratz!


  • Just did this quest on two chars Oct. 3rd, 2010. I tried several of the suggestions below and what absolutely worked on my 2nd toon (with 1:59 secs left) was to get the rods from Sinephobis and immediately plant the first rod right at his feet. Then, take the now-immediate cloud transporter to Gazer Island and go to map location ( 901,464,-6 ) which shows as a yellow POI on the new default EQ2 mapping system. Once there, immediately log to the same character you are now on, doing the quest ( /camp <your name> ). Once you come back, the timer will still be running and the rod will now sucessfully plant. As soon as it's planted, go on over to Bixie Island and do the same camping procedure at map location ( -779,-76,-772 ) again, a yellow dot on the map. As a comment? It would be VERY difficult or almost impossible (imho) to do this part of the quest with any sort of aggro going on; there just isn't enough time. Jeack 09:04, October 3, 2010 (UTC)

Baobap says: this worked fine for me.



  • The main thing to pay attention to on this part of the quest is the 36 second duration of the placed rod. What causes most people to think this part is bugged is they panic and get in a hurry. This causes them to get to Gazer Isle in less than 36 seconds. The rod is a summoned pet with a duration of 36 seconds. If you examine it and read the details it says "Summons a limited pet to aid the caster" (The rod will even take the name of your last summoned pet when placed). Because of this you must not land on the next island in the quest before the 36 seconds has expired. Otherwise the game returns that you have a pet active and you run the risk of bugging this part of the quest.

(As the live update in Aug 2010 made the clouds now teleportation devices this changed the quest. I was able to do the rods in order, placing the first next to sinephobis, the second on Gazer island cloud station and the third on Bixie island cloud station. However, I had to camp to character select and back for both gazer and Bixie before activating the rod or the rod would go grey and i would have to wait for time to run out and go speak to Sinephobis again. It did not matter where else i tried to place the rod or how many seconds in between or what order i did them in. Camping out seemed to be the key!)

  • Different spots may work for different runs of this step. Some people suggest just trying to place the rod at the Sinephobis and at the cloud stations of the two other isles, and, if this does not work on some spot, waiting for the timer to expire, regetting the rods and trying again. If you do not wish to wait for the time to run out, try camping to your character (/camp <character name>). When you return, sometimes the rod works at the cloud station even if it did not before.
  • Alternatively, you may first try placing the rod on the cloud station on a given Isle, and if this does not work, looking for another spot on the Isle.
  • If the spot is not the correct one, the rod's background in your inventory slot will go grey, meaning it is not usable on that location.
  • Keep the inventory slot visible or hotkey the rod and run around the isle until the background turns blue again. This means you've found a spot to place the rod on.
  • Sometimes, a spot right in the middle of monsters will work.
  • There are several suggested spots on each isle on where you might be able to place the rod:
  • On Fear Tainted Isle you can place the rod in front of Sinephobis and at the cloud station. It is suggested you start with this spot, then take cloud to Gazer Isle, and from there to Ravasect Incursion Point and finally to Bixie Isle.
  • On Gazer Isle it might work at the cloud station, but a better bet is to go to the stones in the opening of the U-shaped temple and place it there.
  • On Bixie Isle it may or may not work at the cloud station.
  • Sometimes when redoing this step you may find that you only need to place two rods, not three, within the given time frame.
  • Try this: Stand on the Cloud Station Platform of Bixie and Gazer isle and relog. That will most of the time enable you to place the rods. We did this and the entire party could finish this stage of the quest. Kennin 21:58, 24 July 2008 (UTC)
  • What worked for me was, after many attempts of the rod not activating on Gazer Island, I let time run out. On the next attempt, I placed the rod on fear tainted, then on bixie, then i came back and i was able to place on gazer. This worked for us too - fear tainted, then bixie, then gazer. Standing in the cloud seems to work.
  • If you get to an island and you can't place the rod, try flying to the island you just came from and then back again (if you have time).
  • How many times do you want to do this over again? If you get to an island and it says you can't place the rod, log immediately and when you come back you're able to place the rod.

Components Edit

If you accidentally destroy the instructions you will have to delete the quest and go get the bones again. When you come back, the quest will update with the fact that you have all the required items.

Shaenmo 18:16, 16 June 2009 (UTC)

NOTE: Correction!!!!!! Purple Geodes can only be harvested from firmament stones - not gemstones. I suggest rolling through the ones in the temle of Gazer Isle. You should come up with the goods easily. -Brandon

Dont know what server you are on, but you can buy all the components most of the time for under one gold from the broker and it works...check it out! —Preceding unsigned comment added by (talkcontribs) 22:17, 2010 June 24

Yes, the sheet, lumber, geode and supple leather can be broker-purchased if you are having trouble harvesting them. -- Mysterious drake 04:12, June 25, 2010 (UTC)

As Brandon mentioned previously, the purple geodes do indeed ONLY come from the ore node, not the gem node. In fact, nothing comes from the gem node. I spent a few hours harvesting and ended up with over half of a dozen rare harvests but no quest update. I switched to ore nodes only, and got both the purple geode and the blue-silver sheet from the firmament nodes. This also holds true for Loping Plains, where the geode and sheet only come from the protruding vein (an ore node). I experienced hours of frustration until I figured this out. I have updated the main article accordingly. --Arcturys August 5, 2011

11/17/13 - Confirmed that the quest is still bugged and you need to /camp between placing the rods. Sabershadowkat (talk) 23:45, November 17, 2013 (UTC)

Community content is available under CC-BY-SA unless otherwise noted.